Sabtu, 07 April 2012

Laporan Jarkom 7 : Dynamic Routing

A.     Tujuan
1.       Mampu membangun LAN dan VLAN dalam jaringan
2.       Mampu membuat inter-VLAN Routing.
3.       Mampu memahami konsep routing dan
table routing
4.       Memahami konsep kemanan jaringan

B.     Dasar Teori
Router adalah sebuah alat yang mengirimkan paket data melalui sebuah jaringan atau Internet menuju tujuannya, melalui sebuah proses yang dikenal sebagai routing. Proses routing terjadi pada lapisan 3 dari protokol tumpukan (stack protocol) tujuh-lapis OSI. Router berfungsi sebagai penghubung antar dua atau lebih jaringan untuk meneruskan data dari satu jaringan ke jaringan lainnya. Router berbeda dengan switch. Switch merupakan penghubung beberapa alat untuk membentuk suatu Local Area Network (LAN). Sebagai ilustrasi perbedaan fungsi dari router dan switch merupakan suatu jalanan, dan router merupakan penghubung antar jalan. Masing-masing rumah berada pada jalan yang memiliki alamat dalam suatu urutan tertentu. Dengan cara yang sama, switch menghubungkan berbagai macam alat, dimana masing-masing alat memiliki alamat IP sendiri pada sebuah LAN.
Router sangat banyak digunakan dalam jaringan berbasis teknologi protokol TCP/IP, dan router jenis itu disebut juga dengan IP Router. Selain IP Router, ada lagi AppleTalk Router, dan masih ada beberapa  jenis  router  lainnya.  Internet  merupakan  contoh  utama dari  sebuah jaringan yang memiliki banyak router IP. Router dapat digunakan untuk menghubungkan banyak
jaringan kecil ke sebuah jaringan yang lebih besar, yang disebut dengan internetwork, atau untuk membagi sebuah jaringan  besar  ke  dalam  beberapa  subnetwork  untuk  meningkatkan  kinerja  dan  juga mempermudah manajemennya. Router juga kadang digunakan untuk mengoneksikan dua buah jaringan yang menggunakan media yang berbeda (seperti halnya router wireless yang pada umumnya selain ia dapat menghubungkan komputer dengan menggunakan radio, ia juga mendukung penghubungan komputer dengan kabel UTP), atau berbeda arsitektur jaringan, seperti halnya dari Ethernet ke Token Ring.
Router juga dapat digunakan untuk menghubungkan LAN ke sebuah layanan telekomunikasi seperti halnya telekomunikasi leased line atau Digital Subscriber Line (DSL). Router yang digunakan untuk  menghubungkan  LAN  ke  sebuah  koneksi  leased  line  seperti  T1,  atau
T3,  sering  disebut sebagai access server. Sementara itu, router yang digunakan untuk menghubungkan jaringan lokal ke sebuah koneksi DSL disebut juga dengan DSL router. Router-router jenis tersebut umumnya memiliki fungsi firewall untuk melakukan penapisan paket berdasarkan alamat sumber dan alamat tujuan paket tersebut, meski beberapa router tidak memilikinya. Router yang memiliki fitur penapisan paket  disebut  juga  dengan packet-filtering router.  Router umumnya  memblokir  lalu lintas data yang dipancarkan secara broadcast sehingga dapat mencegah adanya broadcast storm yang mampu memperlambat kinerja jaringan.

Jenis Router
Secara umum, router dibagi menjadi dua buah jenis, yakni :
a.      Static router (router statis)
adalah sebuah router yang memiliki tabel routing statis yang di setting secara manual oleh
para administrator jaringan.
b.     Dynamic router (router dinamis)
adalah sebuah router yang memiliki dan membuat tabel routing dinamis, dengan mendengarkan lalu lintas jaringan dan juga dengan saling berhubungan dengan router lainnya.

Bentuk Router
Berdasarkan bentuk nya dibagi menjadi 3, yaitu :
a.       Router PC
Router PC adalah komputer dengan sistem operasi yang memiliki fasilitas untuk membagi dan men-sharing IP Address. Perangkat jaringan (PC) yang terhubung ke komputer tersebut akan dapat  menikmati  IP  Address  atau  koneksi  internet yang  disebarkan  oleh sistem  operasi tersebut. Contoh sistem operasi yang dapat digunakan adalah semua sistem operasi berbasis client-server, seperti Windows NT, Windows NT
4.0, Windows 2000 server, Windows 2003 Server, MikroTik (Berbasis Linux), dan
lain-lain.
                         
b.      Router Aplikasi
Router  aplikasi  adalah  aplikasi yang dapat di-install pada sistem operasi sehingga  sistem operasi  tersebut akan  memiliki  kemampuan  seperti  router.  Contoh  aplikasi  ini  adalah Winroute, WinGate, SpyGate, dan WinProxy.

c.       Router Hardware
Router hardware adalah hardware yang memiliki kemampuan seperti router sehingga dari hardware tersebut dapat memancarkan atau membagi IP Address dan men-sharing IP Address. Pada  prakteknya  router hardware  digunakan  untuk  membagi  koneksi  internet
pada  suatu ruang atau wilayah. Contoh dari router ini adalah router buatan pabrik seperti Cisco dan Planet.

Algoritma Dynamic Routing
Router Dinamis adalah Router yang me-rute-kan jalur yang dibentuk secara otomatis oleh router itu  sendiri sesuai dengan  konfigurasi yang dibuat. Jika  ada perubahan topologi  antar  jaringan, router otomatis akan membuat ruting yang baru. Dynamic routing biasanya digunakan untuk mengantisipasi kelemahan static routing yang tidak dapat mencari jalur alternative jika jalur pengiriman putus sehingga pake data tidak dapat terkirim. Dynamic routing secara umum dapat dibagi menjasi 2 kategori, yaitu Distance Vector dan link state routing protocol. antara lain: Routing Information Protocol (RIP), Interior Gateway Routing Protocol (IGRP), Enhanced Interior Gateway Routing Protocol (EIGRP),Open Shortest Path First (OSPF).
Sebuah dynamic routing dibangun berdasarkan informasi yang dikumpulkan oleh protokol routing. Protokol ini didesain untuk mendistribusikan informasi yang secara dinamis mengikuti perubahan kondisi jaringan. Protokol routing mengatasi situasi routing yang kompleks secara cepat dan akurat. Protokol routng didesain tidak hanya untuk mengubah ke rute backup bila rute utama tidak berhasil, namun juga didesain untuk menentukan rute mana yang terbaik untuk mencapai tujuan tersebut. Pengisian dan pemeliharaan tabel routing tidak dilakukan secara manual oleh admin. Router saling bertukar informasi routing agar dapat mengetahui  alamat tujuan dan menerima tabel routing. Ada dua jenis algoritma dynamic routing yaitu ;

a)     Distance Vector
Algoritma routing distance vector secara periodik menyalin table routing dari router ke router. Perubahan table routing ini di-update antar router yang saling berhubungan saat terjadi perubahan topologi. Setiap router menerima table routing dari router tetangga yang terhubung secara langsung. Proses routing ini disebut juga dengan routing Bellman-Ford atau Ford-Fulkerson.
Routing  vektor  jarak beroperasi  dengan  membiarkan  setiap  router  menjaga tabel (sebuah vektor) memberikan jarak yang terbaik yang dapat diketahui ke setiap tujuan dan saluran yang dipakai menuju tujuan tersebut. Tabel-tabel ini di-update dengan cara saling bertukar informasi dengan router tetangga. Routing distance vektor bertujuan untuk menentukan arah atau vektor dan jarak ke link-link lain di suatu internetwork. Sedangkan link-state bertujuan untuk menciptakan kembali topologi yang benar pada suatu internetwork.
Update table routing dilakukan ketika terjadi perubahan toplogi jaringan. Sama dengan proses discovery, proses update perubahan topologi step-by-step dari router ke router. Gambar diatas menunjukkan algoritma distance vector memanggil ke semua router untuk mengirim ke isi table routing-nya. Table routing berisi informasi tentang total path cost yang ditentukan oleh metric dan alamat logic dari router pertama dalam jaringan yang ada di isi table routing, seperti skema oleh Analogi distance vector dapat dianalogikan dengan jalan tol. Tanda yang menunjukkan titik ke tujuan dan menunjukkan jarak ke tujuan. Dengan adanya tanda-tanda seperti itu pengendara dapat dengan mudah mengetahui perkiraan arak yang akan ditempuh untuk mencapai tujuan. Dan tentunya jarak terpendek adalah rute yang terbaik.

b)     Link State
Algoritma link-state juga dikenal dengan algoritma Dijkstra atau algoritma shortest path first (SPF). Algoritma ini memperbaiki informasi database dari informasi topologi. Algoritma distance vector memiliki informasi yang tidak spesifik tentang distance network dan tidak mengetahui jarak router. Sedangkan algortima link-state memperbaiki pengetahuan dari jarak router dan bagaimana mereka inter-koneksi.
Beberapa fitur yang dimiliki oleh routing link-state adalah:
1)      Link-state advertisement (LSA) – paket kecil dari informasi routing yang dikirim antar router.
2)      Topological database – kumpulan informasi yang dari LSA-LSA.
3)      SPF algorithm – hasil perhitungan pada database sebagai hasil dari pohon SPF.
4)      Routing table – adalah daftar rute dan interface.

Konsep dari algoritma link state sebagai berikut :
1)      Setiap router mempunyai peta jaringan,
2)      Router  menentukan  rute  ke  setiap  tujuan di  jaringan  berdasarkan peta  jaringan tersebut.
3)      Peta jaringan disimpan router dalam bentuk database sebagai hasil dari pertukaran info link-state antara router-router bertetangga di jaringan tersebut.
4)      Setiap record dalam database menunjukkan status sebuah jalur dijaringan (link-tate).
5)      Menerapkan algoritma Dijkstra.
6)      Topologi jaringan dan link cost diketahui oleh semua node router.
7)      Dilakukan dengan cara mem-broadcast informasi link state.
8)      Semua node memiliki informasi yang sama.
9)      Menghitung cost terkecil dari satu node ke node lainnya.
10)   Memberikan tabel rute untuk router tersebut setelah iterasi sebanyak n, diketahui link cost terkecil untuk n tujuan.

Protocol Dynamic Routing
1)      RIP (Routing Information Protocol)
Routed protocol digunakan untuk user traffic secara langsung. Routed protocol
menyediakan informasi yang cukup dalam layer address jaringannya untuk melewatkan paket yang akan diteruskan dari satu host ke host yang lain berdasarkan alamatnya.
RIP merupakan salah satu protokol routing distance vector yang digunakan oleh
ribuan jaringan di dunia. Hal ini dikarenakan RIP berdasarkan open standard dan mudah diimplementasikan. Tetapi RIP membutuhkan konsumsi daya yang tinggi dan memerlukan fitur router routing protokol. Dasar RIP diterangkan dalam RFC 1058, dengan karakteristik sebagai berikut :
1)      Routing protokol distance vector.
2)      Metric berdasarkan pada jumlah lompatan (hop count) untuk pemilihan jalur,
3)      Jika hop count lebih dari 15, maka paket dibuang,
4)      Update routing dilakukan secara broadcast setiap 30 detik.
Berikut adalah 2 versi RIP yang digunakan dalan dynamic routing :
a)      RIP versi 1
Ø      Dokumen RFC1058.
Ø     RIPv1 routing vector jarak yang dimodifikasi dengan triggered update dan split horizon dengan poisonous reverse untuk meningkatkan kinerjanya.
Ø     RIPv1 diperlukan supaya host dan router dapat bertukar informasi untuk menghitung route dalam jaringan TCP/IP.
Ø     Informasi yang diperlukan RIPv1 berupa host, network, subnet dan rute default.
b)      RIP versi 2
Ø     Enhancement dari RIPv1 ditambah dengan beberapa kemampuan baru,
Ø     Algoritma routing sama dengan RIPv1, bedanya terletak pada format dengan tambahan informasi yang dikirim,
Ø     Kemampuan baru; tag untuk route eksternal, subnet mask, alamat hop berikutnya, autentifikasi.


2)      EIGRP (Enhanced Interior Gateway Routing Protocol)
Adalah salah satu routing protocol yang bersifat proprietary dari Cisco System yang di
rilis pada tahun 1992. Disebut sebagai proprietary karena routing protocol EIGRP ini hanya bisa digunakan sesama router cisco, tidak untuk router yang lain. Dilihat dari namanya dapat disimpulkan, EIGRP adalah “pengkayaan” dari IGRP (Interior Gateway Routing Protocol). EIGRP menggunakan formula berbasis bandwidth dan delay untuk menghitung metric yang sesuai untuk rute. EIGRP melakukan konvergensi secara tepat ketika menghindari loop. EIGRP tidak melakukan perhitungan-perhitungan rute seperti yang dilakukan oleh protocol link state. Hal ini membuat EIGRP tidak memputuhkan delay extra, sehingga hanya memerlukan lebih sedikit memori dan proses dibandingkan dengan protocol link state. Konvergensi EIGRP lebih cepat dibandingkan protocol distance vector
lainnya, hal ini di sebabkan karena EIGRP tidak memerlukan loop avoidance yang pada kenyataannya menyebabkan protocol distance vector melambat. EIGRP mengurangi pembebanan di jaringan karena hanya mengirim sebagian dari routing update, EIGRP tidak akan mengirimkan update jika tidak ada perubahan. Jika ada perubahan, langsung update dilakukan, akan tetapi hanya mengirim update kepada yang terkena imbas update.
EIGRP sering pula disebut hybrid-distance vector routing protocol, hal ini dikarenakan EIGRP seperti memiliki dua tipe routing protocol yang di gunakan yaitu distance vector dan link state. Akan tetapi walaupun EIGRP mmpunyai kemampuan seperti link-state routing protocol, EIGRP tetaplah distant vector routing protocol, oleh sebab itulah dalam kurikulum cisco, kata hybrid routing protocol dihapuskan atau tidak dipergunakan. Dalam perhitungan untuk menentukan jalur mana yang terpendek, EIGRP menggunakan algoritma DUAL (Diffusing Update Algorithm) dalam menentukannya, DUAL juga memiliki fungsi menyiapkan backup dan memastikan backup loop-free. EIGRP memiliki karakteristik sebagai berikut ;
ð      Reliable Transport Protocol (RTP)
ð      Bounded Updates
ð      Diffusing Update Algorithm (DUAL)
ð      Establishing Adjacencies
ð      Neighbor and Topology Tables
Kelebihan EIGRP dibanding routing protocol lainnya:
·        Satu-satunya routing protocol yang menggunakan route backup.
·        Mudah di konfigurasi, semudah RIP
·        Summarization dapat dilakukan dimana saja dan kapan saja
·        EIGRP satu satunya routing protocol yang dapat melakukan unequal load balancing
·        Kombinasi terbaik dari protocol distance vector dan link-state

3)      OSPF (Open Shortest Path First)
adalah link-state routing protokol yang dikembangkan sebagai pengganti untuk distance vector routing protocol RIP. RIP merupakan routing protocol yang digunakan pada
awal perkembangan jaringan dan Internet, tetapi ketergantungan pada hop sebagai satu-satunya ukuran untuk memilih rute terbaik dan cepat menjadi tidak dapat diterima dalam jaringan yang lebih besar yang membutuhkan solusi routing lebih kuat. OSPF adalah protokol routing tanpa kelas (classless) yang menggunakan konsep area untuk skalabilitas. RFC 2328 mendefinisikan metrik OSPF sebagai cost. IOS Cisco menggunakan bandwidth
sebagai penentu cost metric OSPF. Keunggulan utama OSPF setelah berakhirnya RIP adalah konvergensi yang cepat dan skalabilitas untuk implementasi jaringan yang jauh lebih besar.


4)      Redistributed Routing Protokol
Redistribute adalah cara untuk meredistribusikan kembali routing tabel yang dibentuk oleh suatu routing protocol untuk diteruskan ke routing protocol lain. Dengan redistribute kita bisa membentuk routing tabel yang lengkap dari suatu topologi walaupun menggunakan routing protocol yang berbeda. Pada prinsipnya router yang menjadi penghubung antara network dengan routing protocol yang berbeda akan menggunakan routing protocol sesuai dengan routing protocol yang dipergunakan oleh kedua network tersebut, misal interface f0/0 pada router tersebut berhubungan dengan network yang menggunakan RIP maka router tersebut harus menggunakan RIP dan pada F0/1 menggunakan OSPF maka router tersebut juga harus menggunakan OSPF sesuai dengan network tempat interface tersebut terhubung. Untuk membuat agar routing tabel yang dibentuk oleh RIP bisa diteruskan menuju ke OSPF maka dipergunakan redistribute RIP, dan sebaliknya agar routing tabel yang terbentuk pada OSPF bisa diteruskan menuju RIP maka dipergunakanlah redistribute OSPF.

C.     Skenario Praktik
Dalam sebuah perusahaan terdapat tiga buah divisi yang berbeda ip address dan dihubungkan menggunakan beberapa router. Bagaimana seorang network administrator dalam perusahaan tersebut membuat ketiga divisi tersebut dapat saling berkomunikasi?

Dari kebutuhan pada skenario tersebut diatas, seorang network administrator membuat simulasinya pada paket tracert dengan dynamic routing menggunakan protokol RIPv2, OSPF dan EIGRP.
D.     Alat dan Bahan
1.       Software Paket Tracert 5.3
2.       PC/Laptop

E.    Langkah Kerja
1.       Simulasi menggunakan protocol RIPv2
1)      Buat jaringan network seperti berikut
Tabel Routing Router A

No

Destination

Netmask

Gateway

Interface

Keterangan

1

192.168.1.0

/24

*

eth0

Direct
Connection

2

192.168.2.0

/24

*

eth1

Direct
Connection

3

192.168.3.0

/24

192.168.2.253

eth0

Indirect
Connection

4

192.168.4.0

/24

192.168.2.253

eth0

Indirect
Connection

5

192.168.5.0

/24

192.168.3.253

eth0

Indirect
Connection

Tabel Routing Router B

No

Destination

Netmask

Gateway

Interface

Keterangan

1

192.168.1.0

/24

192.168.2.254

eth1

Indirect
Connection

2

192.168.2.0

/24

*

eth0

Direct
Connection

3

192.168.3.0

/24

*

eth1

Direct
Connection

4

192.168.4.0

/24

*

eth2

Direct
Connection

5

192.168.5.0

/24

192.168.3.253

eth0

Indirect
Connection

Tabel Routing Router C

No

Destination

Netmask

Gateway

Interface

Keterangan

1

192.168.1.0

/24

192.168.2.254

eth1

Indirect
Connection

2

192.168.2.0

/24

192.168.3.254

eth1

Indirect
Connection

3

192.168.3.0

/24

*

eth0

Direct
Connection

4

192.168.4.0

/24

192.168.3.254

eth1

Indirect
Connection

5

192.168.5.0

/24

*

eth1

Direct
Connection

2)      Konfigurasi
·        Router A
·        Double click router A kemudian pilih CLI
Router>enable
Router#configure terminal
·        Setting IP Address Router A eth0 (example pada fa0/0) ke switch
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.1.254 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router A eth1 (example pada fa0/1) ke Router B
Router(config)#interface fa0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.2.254 255.255.255.0
Router(config-if)#exit
·        Tambahkan informasi pada table routing pada Router A
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#exit
·        Lihat hasil konfigurasi static routing pada router A
Router#show ip route

·        Router B
·         Double click router B kemudian pilih CLI
Router>enable
Router#configure terminal
·        Setting IP Address Router B eth0 (example pada fa0/0) ke Router A
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.2.253 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router B eth1 (example pada fa0/1) ke Router C
Router(config)#interface fa0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.3.254 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router B 2 (example pada Et0/0/1) ke Switch
Router(config)#interface et0/0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.4.254 255.255.255.0
Router(config-if)#exit
·        Tambahkan informasi pada table routing pada Router B
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.41.0
Router(config-router)#exit
Router(config)#exit
·        Lihat hasil konfigurasi static routing pada router B
Router#show ip route

·        Router C
·         Double click router C kemudian pilih CLI
Router>enable
Router#configure terminal
·        Setting IP Address Router C eth1 (example pada fa0/1) ke Router B
Router(config)#interface fa0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.3.253 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router C eth0 (example pada fa0/0) ke switch
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.5.254 255.255.255.0
Router(config-if)#exit
·        Tambahkan informasi pada table routing pada Router C
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.5.0
Router(config-router)#exit
Router(config)#exit
·        Lihat hasil konfigurasi static routing pada router C
Router#show ip route

3)      Cek hasil pada komputer client
Jika dari semua komputer tersebut dapat saling berkomunikasi maka konfigurasi dynamic routing dengan RIPv2 sudah berhasil. Selain dicek dengan perintah ping, juga dicek dengan perintah tracert “ip address terget”.

2.      Simulasi menggunakan protocol OSPF
1)      Buat jaringan network seperti berikut

Tabel Routing Router A

No

Destination

Netmask

Gateway

Interface

Keterangan

1

192.168.1.0

/24

*

eth0

Direct
Connection

2

192.168.2.0

/24

*

eth1

Direct
Connection

3

192.168.3.0

/24

192.168.2.253

eth0

Indirect
Connection

4

192.168.4.0

/24

192.168.2.253

eth0

Indirect
Connection

5

192.168.5.0

/24

192.168.3.253

eth1

Indirect
Connection

Tabel Routing Router B

No

Destination

Netmask

Gateway

Interface

Keterangan

1

192.168.1.0

/24

192.168.2.254

eth1

Indirect
Connection

2

192.168.2.0

/24

*

eth0

Direct
Connection

3

192.168.3.0

/24

*

eth1

Direct
Connection

4

192.168.4.0

/24

*

eth2

Direct
Connection

5

192.168.5.0

/24

192.168.3.253

eth0

Indirect
Connection

Tabel Routing Router C

No

Destination

Netmask

Gateway

Interface

Keterangan

1

192.168.1.0

/24

192.168.2.254

eth1

Indirect
Connection

2

192.168.2.0

/24

192.168.3.254

eth1

Indirect
Connection

3

192.168.3.0

/24

*

eth0

Direct
Connection

4

192.168.4.0

/24

192.168.3.254

eth1

Indirect
Connection

5

192.168.5.0

/24

*

eth1

Direct
Connection

2)      Konfigurasi
·        Router A
·         Double click router A kemudian pilih CLI
Router>enable
Router#configure terminal
·        Setting IP Address Router A eth0 (example pada fa0/0) ke switch
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.1.254 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router A eth1 (example pada fa0/1) ke Router B
Router(config)#interface fa0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.2.254 255.255.255.0
Router(config-if)#exit
·        Tambahkan informasi pada table routing pada Router A
Router(config)#router ospf 1
Router(config-router)#network 192.168.1.0   0.0.0.255 area 0
Router(config-router)#network 192.168.2.0   0.0.0.255 area 0
Router(config-router)#exit
Router(config)#exit
·        Lihat hasil konfigurasi static routing pada router A
Router#show ip route

·        Router B
·         Double click router B kemudian pilih CLI
Router>enable
Router#configure terminal
·        Setting IP Address Router B eth0 (example pada fa0/0) ke Router A
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.2.253 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router B eth1 (example pada fa0/1) ke Router C
Router(config)#interface fa0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.3.254 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router B 2 (example pada Et0/0/1) ke Switch
Router(config)#interface eth0/0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.4.254 255.255.255.0
Router(config-if)#exit
·        Tambahkan informasi pada table routing pada Router B
Router(config)#router ospf 1
Router(config-router)#network 192.168.2.0   0.0.0.255 area 0
Router(config-router)#network 192.168.3.0   0.0.0.255 area 0
Router(config-router)#network 192.168.4.0   0.0.0.255 area 0
Router(config-router)#exit
Router(config)#exit
·        Lihat hasil konfigurasi static routing pada router B
Router#show ip route

·        Router C
·         Double click router C kemudian pilih CLI
Router>enable
Router#configure terminal
·        Setting IP Address Router C eth1 (example pada fa0/1) ke Router B
Router(config)#interface fa0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.3.253 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router C eth0 (example pada fa0/0) ke switch
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.5.254 255.255.255.0
Router(config-if)#exit
·        Tambahkan informasi pada table routing pada Router C
Router(config)#router ospf
Router(config-router)#network 192.168.3.0   0.0.0.255 area 0
Router(config-router)#network 192.168.5.0   0.0.0.255 area 0
Router(config-router)#exit
Router(config)#exit
·        Lihat hasil konfigurasi static routing pada router C
Router#show ip route

3)      Cek hasil pada komputer client
Jika dari semua komputer tersebut dapat saling berkomunikasi maka konfigurasi dynamic routing dengan OSPF sudah berhasil. Selain dicek dengan perintah ping, juga dicek dengan perintah tracert “ip address terget”.

Keterangan command prompt diatas :
a)      Router ospf 1
Angka 1 adalah Process-id merupakan nomor antara 1 – 65535 yang ditentukan oleh system administrator. Process-id digunakan untuk menentukan nomor dari OSPF yang digunakan. Biasanya dalam suatu topologi jaringan, digunakan process-id yang sama agar memudahkan dalam konfigurasi.
b)      Network 192.168.3.0 0.0.0.255 area 0
Angka 0.0.0.255 adalah Wildcard mask. Wildcard mask merupakan kebalikan dari subnet mask. Jika subnet mask adalah 255.255.255.0 maka wildcard mask nya adalah 0.0.0.255. angka binary 0 pada subnet mask diubah menjadi angka
binary 1 pada wildcard mask.
Area 0 adalah area-id. Area-id pada OSPF merupakan nilai antara 0–4294967295 yang ditentukan oleh system administrator. Area-id menjadi identitas untuk setiap router dengan area-id yang sama untuk berbagi tentang informasi link-state. Router dengan area-id yang sama pasti memiliki informasi link-state yang sama di database link-state nya. Area-id dapat disetting menajid single area (area 0 saja) atau multi area (terdiri dari banyak area). Area 0 digunakan sebagai backbone area atau area yang menjadi core network. Sedangkan area lain
menjadi support area, biasanya area dengan jaringan kecil.

3.      Simulasi menggunakan protocol EIGRP
1)      Buat jaringan network seperti berikut

Tabel Routing Router A

No

Destination

Netmask

Gateway

Interface

Keterangan

1

192.168.1.0

/24

*

eth0

Direct
Connection

2

192.168.2.0

/24

*

eth1

Direct
Connection

3

192.168.3.0

/24

192.168.2.253

eth0

Indirect
Connection

4

192.168.4.0

/24

192.168.2.253

eth0

Indirect
Connection

5

192.168.5.0

/24

192.168.3.253

eth1

Indirect
Connection

Tabel Routing Router B

No

Destination

Netmask

Gateway

Interface

Keterangan

1

192.168.1.0

/24

192.168.2.254

eth1

Indirect
Connection

2

192.168.2.0

/24

*

eth0

Direct
Connection

3

192.168.3.0

/24

*

eth1

Direct
Connection

4

192.168.4.0

/24

*

eth2

Direct
Connection

5

192.168.5.0

/24

192.168.3.253

eth0

Indirect
Connection

Tabel Routing Router C

No

Destination

Netmask

Gateway

Interface

Keterangan

1

192.168.1.0

/24

192.168.2.254

eth1

Indirect
Connection

2

192.168.2.0

/24

192.168.3.254

eth1

Indirect
Connection

3

192.168.3.0

/24

*

eth0

Direct
Connection

4

192.168.4.0

/24

192.168.3.254

eth1

Indirect
Connection

5

192.168.5.0

/24

*

eth1

Direct
Connection

2)      Konfigurasi
·        Router A
·         Double click router A kemudian pilih CLI
Router>enable
Router#configure terminal
·        Setting IP Address Router A eth0 (example pada fa0/0) ke switch
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.1.254 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router A eth1 (example pada fa0/1) ke Router B
Router(config)#interface fa0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.2.254 255.255.255.0
Router(config-if)#exit
·        Tambahkan informasi pada table routing pada Router A
Router(config)#router EIGRP 1
Router(config-router)#network 192.168.1.0 
Router(config-router)#network 192.168.2.0   
Router(config-router)#exit
Router(config)#exit
·        Lihat hasil konfigurasi static routing pada router A
Router#show ip route

·        Router B
·         Double click router B kemudian pilih CLI
Router>enable
Router#configure terminal
·        Setting IP Address Router B eth0 (example pada fa0/0) ke Router A
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.2.253 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router B eth1 (example pada fa0/1) ke Router C
Router(config)#interface fa0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.3.254 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router B 2 (example pada Et0/0/1) ke Switch
Router(config)#interface eth0/0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.4.254 255.255.255.0
Router(config-if)#exit
·        Tambahkan informasi pada table routing pada Router B
Router(config)#router eigrp 1
Router(config-router)#network 192.168.2.0  
Router(config-router)#network 192.168.3.0  
Router(config-router)#network 192.168.4.0  
Router(config-router)#exit
Router(config)#exit
·        Lihat hasil konfigurasi static routing pada router B
Router#show ip route

·        Router C
·         Double click router C kemudian pilih CLI
Router>enable
Router#configure terminal
·        Setting IP Address Router C eth1 (example pada fa0/1) ke Router B
Router(config)#interface fa0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.3.253 255.255.255.0
Router(config-if)#exit
·        Setting IP Address Router C eth0 (example pada fa0/0) ke switch
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.5.254 255.255.255.0
Router(config-if)#exit
·        Tambahkan informasi pada table routing pada Router C

0 komentar:

Poskan Komentar